[squeak-dev] LargeInteger parsing (?) broken between 5.2b and update 18615

David T. Lewis lewis at mail.msen.com
Mon Jul 22 12:22:08 UTC 2019

On Sun, Jul 21, 2019 at 09:15:41PM -0700, tim Rowledge wrote:
> Well, this is interesting; After updating my Pi VM (to the squeak.cog.spur_linux32ARMv6_201907192337.tar.gz version from the squeak.org inked bintray stuff) and getting no change - I hoped perhaps we'd updated the largeint plugin or something like that - I copied the image across to my iMac and tried the problematic compile there; no problem.
> The Mac vm is a plain 5.2b release vm. Both are 32 bit (because the Pi does not yet do 64 bit). Happy happy; VM debugging time. There's a pleasure I haven't had in a while...
> Anyone wanting to check things out can obtain a copy of the image and recent crash.dmp etc on request.

I just tried your test on my Ubuntu Intel machine with a locally compiled VM,
and I see no problem.

Suggestion: Recompile your VM with optimization turned off ( -O0 compiler flag)
and see if the problem goes away.

For reference, my VM is:

  Virtual Machine
  Croquet Closure Cog[Spur] VM [CoInterpreterPrimitives VMMaker.oscog-eem.2523]
  Unix built on Jun 20 2019 12:05:41 Compiler: 5.4.0 20160609
  platform sources revision VM: 201903061925 lewis at lewis-Gazelle-Pro:squeak/git/opensmalltalk-vm Date: Wed Mar 6 11:25:10 2019 CommitHash: 2ede003 Plugins: 201903061925 lewis at lewis-Gazelle-Pro:squeak/git/opensmalltalk-vm
  CoInterpreter VMMaker.oscog-eem.2523 uuid: 1d88061f-236d-40fd-a739-30fe691d0606 Jun 20 2019
  StackToRegisterMappingCogit VMMaker.oscog-eem.2521 uuid: 4f1618e4-2a0c-4ba8-be03-b8670286ba00 Jun 20 2019


More information about the Squeak-dev mailing list