[squeak-dev] The Inbox: Tools-ct.900.mcz
marcel.taeumel at hpi.de
Thu Nov 21 16:32:29 UTC 2019
any news about this refactoring? You offered to rename "slotSpecs" :-) What about InspectorFieldSpec?
Am 10.11.2019 20:05:24 schrieb Christoph Thiede <christoph.thiede at student.hpi.uni-potsdam.de>:
Chris Muller-4 wrote
> I meant a single class which simply gave names to what you're using for
> #key and #value of your Associations. But whether its one class for all
> types, or one class per type, or neither but just a good comment somewhere
> -- the goal is to help future readers unfamiliar with that spec structure
> understand it quickly.
Because of the polymorphy of the spec format (value is either symbol or
symbol-index-pair), I think we rather would need two classes at minimum. I
have always tried to minimize the number of classes, but if you suggest it,
I will give a try to extract such an InspectorFieldSpec class. :-)
Sent from: http://forum.world.st/Squeak-Dev-f45488.html
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Squeak-dev