[squeak-dev] new VM appears not to be flushing

Chris Muller asqueaker at gmail.com
Mon Jan 13 21:58:16 UTC 2020

Hi Eliot,

> We're talking linux right?


> So the only change I see since Alistair's commit in 2018 is Nicolas'
change that has to be harmless:

Thanks for checking those recent commits, I was hoping we'd be able to
pinpoint an obvious cause.  Hm, so it could be something else with
FileStream besides #flush that's causing the test to fail..  Hm.

Can you provide the version info for both please?

The old I'm testing with is:

   Unix built on Nov 27 2018 23:46:03 Compiler: 4.8.4
   platform sources revision VM: 201811272342
https://github.com/OpenSmalltalk/opensmalltalk-vm.git Date: Tue Nov 27
15:42:06 2018 CommitHash: 476f7060

While the new one is the one Fabio posted the other day.

    platform sources revision VM: 201912311458
https://github.com/OpenSmalltalk/opensmalltalk-vm.git Date: Tue Dec 31
15:58:24 2019 CommitHash: f219b72


The issue is easily recreatable by running Magma's test suite, but the
failing test is complex and exercises the full DB stack, so I wouldn't
expect you to try to debug anything that way.

With the new VM, I just tried a manual StandardFileStream in an inspector,
did a #nextPutAll:, and verified the file contents in another window
weren't there until after I did #flush.  So, it does appear that flush
worked at least in that simple scenario.  I may have to dig deeper into the
failing test to see if it's a different issue -- now I'm suspecting extra
"buffer" bytes on the end of hte file or something which is throwing off
the computed hash...  I'll try digging deeper and see if I can better
isolate the problem into something you can deal with..

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.squeakfoundation.org/pipermail/squeak-dev/attachments/20200113/16e5124d/attachment.html>

More information about the Squeak-dev mailing list