[squeak-dev] Installer loading cryptography mcm files: used to work (I think) and doesn't now

Robert Withers robert.withers at pm.me
Wed Jun 17 01:54:46 UTC 2020

Hello tim,

Oh dear, I regret hearing about regressions. You chose the correct code 
to load. From thinking about what you have said and the earlier 
Metacello issues from recent changes, I suspect that the 
MCHttpRepository (Is that it's name?) and friends have changed for the 
worse. Would anyone knowledgeable about Metacello be able to look at 
loading MCM files, please?


On 6/16/20 9:44 PM, tim Rowledge wrote:
> A little while back - late May (or as we refer to it around here, very late March) - we had a thread about loading the Cryptography package etc. I'd swear that
> (Installer ss) project: 'Cryptography';  install: 'ProCrypto-1-1-1'.
> worked to load it. There are multiple emails referring to that; it's what rww sugested.
> Today it fails because the two repositories that the read-in MCConfiguration has are set with a location of #nil (not nil, #nil). This is a *plain 5.3-19435 release image, freshly started* and just run the incantation in a workspace. I've tried several older configurations from the Cryptography repository in case I screwed up the mcm file, but no change.   When I examine the mcm files they clearly don't have any repository names in there. I'm baffled how using that install command could have loaded anything.
> Somewhere I must have done some prior required thing in those earlier tests and failed to note it, surely? Right now I'm just assuming this is 2020 having fun with me...
> tim
> --
> tim Rowledge; tim at rowledge.org; http://www.rowledge.org/tim
> Strange OpCodes: RCS: Read Card Sideways

More information about the Squeak-dev mailing list