[squeak-dev] Installer loading cryptography mcm files: used to work (I think) and doesn't now

Levente Uzonyi leves at caesar.elte.hu
Wed Jun 17 03:08:14 UTC 2020

Well, it actually seems to be a squeaksource.com issue. All .mcm files 
served by squeaksource.com seem to be missing their repository 
information. E.g.:


source.squeak.org is not affected by this:



On Wed, 17 Jun 2020, Levente Uzonyi wrote:

> I had a quick look and the breakage seems to come from the recent 
> MonticelloConfigurations changes.
> If you open the configuration browser on any configuration, the reposities 
> of the configuration will not be parsed correctly. Their locations will 
> always be #nil.
> Levente
> On Tue, 16 Jun 2020, tim Rowledge wrote:
>> A little while back - late May (or as we refer to it around here, very late 
> March) - we had a thread about loading the Cryptography package etc. I'd 
> swear that 
>> (Installer ss) project: 'Cryptography';  install: 'ProCrypto-1-1-1'.
>> worked to load it. There are multiple emails referring to that; it's what 
> rww sugested.
>> Today it fails because the two repositories that the read-in 
> MCConfiguration has are set with a location of #nil (not nil, #nil). This is 
> a *plain 5.3-19435 release image, freshly started* and just run the 
> incantation in a workspace. I've tried several older configurations from the 
> Cryptography repository in case I screwed up the mcm file, but no change. 
> When I examine the mcm files they clearly don't have any repository names in 
> there. I'm baffled how using that install command could have loaded anything. 
>> Somewhere I must have done some prior required thing in those earlier tests 
> and failed to note it, surely? Right now I'm just assuming this is 2020 
> having fun with me...
>> tim
>> --
>> tim Rowledge; tim at rowledge.org; http://www.rowledge.org/tim
>> Strange OpCodes: RCS: Read Card Sideways

More information about the Squeak-dev mailing list