[squeak-dev] Installer loading cryptography mcm files: used to work (I think) and doesn't now

Robert Withers robert.withers at pm.me
Wed Jun 17 21:03:30 UTC 2020

I went ahead and updated all the config maps in Cryptography and Oceanside. As you browse the latest version, you will see the nils for repositories. Just delete those and re-add the appropriate repositories and republish. Here are the latest versions with the correct repositories.

> - ProCrypto-1-1-1-rww.16.mcm
> - ProCryptoTests-1-1-1-rww.6.mcm
> - PromisesLoader-rww.5.mcm
> - SSLLoader-rww.35.mcm
> - ston-config-map-rww.2.mcm

Loading these should occur without error.

K, r

On 6/17/20 12:52 PM, David T. Lewis wrote:

> Update - I found the cause, but not yet the fix.
> The repository reference in an update map are cached in the repository
> that lives in the squeaksource.com image. The structure of class
> MCHttpRepository has changed in years between the old ss image and
> the new one, and those repository references were broken in the
> process of converting the old image repository to the new one.
> Next step is figuring out how to fix it.
> Dave
> On Wed, Jun 17, 2020 at 08:54:59AM -0400, David T. Lewis wrote:
>> Confirmed.
>> I do not know the cause, but I'll try to figure it out today. We have
>> been running squeaksource.com on a significantly updated image for
>> about 7 days. Very likely that is when the problem first appeared.
>> Dave
>> On Wed, Jun 17, 2020 at 05:08:14AM +0200, Levente Uzonyi wrote:
>>> Well, it actually seems to be a squeaksource.com issue. All .mcm files
>>> served by squeaksource.com seem to be missing their repository
>>> information. E.g.:
>>> http://squeaksource.com/OSProcess/update-dtl.mcm
>>> http://squeaksource.com/Cryptography/ProCrypto-1-1-1-tpr.15.mcm
>>> http://squeaksource.com/PostgresV3/update-ul.1.mcm
>>> source.squeak.org is not affected by this:
>>> https://source.squeak.org/trunk/update-mt.475.mcm
>>> Levente
>>> On Wed, 17 Jun 2020, Levente Uzonyi wrote:
>>>> I had a quick look and the breakage seems to come from the recent
>>>> MonticelloConfigurations changes.
>>>> If you open the configuration browser on any configuration, the reposities
>>>> of the configuration will not be parsed correctly. Their locations will
>>>> always be #nil.
>>>> Levente
>>>> On Tue, 16 Jun 2020, tim Rowledge wrote:
>>>>> A little while back - late May (or as we refer to it around here, very
>>>>> late
>>>> March) - we had a thread about loading the Cryptography package etc. I'd
>>>> swear that
>>>>> (Installer ss) project: 'Cryptography';  install: 'ProCrypto-1-1-1'.
>>>>> worked to load it. There are multiple emails referring to that; it's what
>>>> rww sugested.
>>>>> Today it fails because the two repositories that the read-in
>>>> MCConfiguration has are set with a location of #nil (not nil, #nil). This
>>>> is a *plain 5.3-19435 release image, freshly started* and just run the
>>>> incantation in a workspace. I've tried several older configurations from
>>>> the Cryptography repository in case I screwed up the mcm file, but no
>>>> change. When I examine the mcm files they clearly don't have any
>>>> repository names in there. I'm baffled how using that install command
>>>> could have loaded anything.
>>>>> Somewhere I must have done some prior required thing in those earlier
>>>>> tests
>>>> and failed to note it, surely? Right now I'm just assuming this is 2020
>>>> having fun with me...
>>>>> tim
>>>>> --
>>>>> tim Rowledge;
>>>>> tim at rowledge.org
>>>>> ;
>>>>> http://www.rowledge.org/tim
>>>>> Strange OpCodes: RCS: Read Card Sideways
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.squeakfoundation.org/pipermail/squeak-dev/attachments/20200617/a6b3f53b/attachment.html>

More information about the Squeak-dev mailing list