[squeak-dev] [ERROR}[5.3] building ByteArrays from HEX strings are now failing

Robert robert.withers at pm.me
Wed Mar 4 15:50:39 UTC 2020

Hi yo hehr, Nicolas,

I tried the first block, in the simulation window, but it was missing BochsIA64 or some. I then ran the third block, a StackVM as you suggested. I ran it against my Cryptography repair image, rabbit, and very slooowly reselected the tests and ran them, in proogrress...

We sure would be appreciating etwas help, as if there was a little angel out there who offers plugin repair and SHA512 code/plugin. Praying for an angel!

tyk, r

On 3/4/20 8:50 AM, Nicolas Cellier wrote:

> Hi Robert,
> normally, most of VM/plugins development should take place with the VM-simulation from within the SpurVMMaker.image  (unless the plugin extensively call C functions from external libraries).
> You will find a Worksapce with some simulation examples.
> Then you might detect the error from within Smalltalk with debuggers etc...
> I recommend simulating a Stack VM for a beginning (or you'll need to compile the Bochs plugin, which is currently difficult on linux...).
> Le mer. 4 mars 2020 à 14:40, Robert via Squeak-dev <squeak-dev at lists.squeakfoundation.org> a écrit :
>> Hi Levente,
>> Yes, I see what you are saying. Without the Crypto plugins, all the Crypto tests run green.
>> With the Crypto plugins, things get messed up. ByteArray class>>#fromHexString: still completes, but the KeyHolder>>#key SEG-FAULTS the vm (called from CryptoRC2Test>>#testARC2). Additionally, the following two tests fail: CryptoDESTest>>#testDESCBC and CryptoDESTest>>#testTripleDESCBC.
>> The SEG-FAULT comes from this code:
>> KeyHolder new
>>     data: KeyHolderData new;
>>     encryptKey: #(0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0) asByteArray;
>>     key
>> tyk, r
>> On 3/4/20 8:10 AM, Levente Uzonyi wrote:
>>> Hi Robert,
>>> I just ran all test cases of Cryptography-v5.3-rww.118.mcz in a fresh 5.3
>>> image on 64-bit linux using the stock VM (no Cryptography plugins), and
>>> all the tests are green.
>>> ByteArray class >> #fromHexString: and methods sent by it were last
>>> modified in 2010, and they do not accept non-hexadecimal digits in the
>>> input string.
>>> Levente
>>> On Wed, 4 Mar 2020, Robert via Squeak-dev wrote:
>>>> In squeak 5.3, building ByteArrays from HEX strings are now failing,
>>>> after years of passing within the Cryptography tests.
>>>> The first doIt works, while the other two are now failing in the
>>>> #readHexFrom: method...
>>>> ByteArray fromHexString: '06a9214036b8a15b512e03d534120006'
>>>> ByteArray fromHexString: '16rc286696d887c9aa0611bbb3e2025a45a'
>>>> ByteArray fromHexString: '00000000 00000000'
>>>> This is causing multiple test failures in the Cryptography test suite.
>>>> tyk, r
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.squeakfoundation.org/pipermail/squeak-dev/attachments/20200304/30330834/attachment.html>

More information about the Squeak-dev mailing list