[squeak-dev] Squeak5.3 linux ARMv6 segfaults on startup

Nicolas Cellier nicolas.cellier.aka.nice at gmail.com
Sun Mar 8 10:23:48 UTC 2020


Hi all,
several questions:
- what test do we pass on CI for ARM?
- can we debug it from the VMSimulator?
I have compiled the GdbArmPlugin on macos, but I do not know how to force
the simulator to use ISA ARMv5...
What is the incantation?

Le dim. 8 mars 2020 à 10:10, Fabio Niephaus <lists at fniephaus.com> a écrit :

> What's a viable solution? Revert the ARMv6 VM to the one we used for
> Squeak 5.2?
>
> Fabio
>
> On Sun, 8 Mar 2020 at 10:01 am, Bruce O'Neel <bruce.oneel at pckswarms.ch>
> wrote:
>
>>
>> Hi,
>>
>> I have the same result.  Download the release to my Pi3, unzip, run,
>> crash on startup.
>>
>> The stack VM I built about 1 March works fine.
>>
>> cheesr
>>
>>
>> bruce
>>
>>
>>
>> *08 March 2020 09:41 Nicolas Cellier <nicolas.cellier.aka.nice at gmail.com
>> <nicolas.cellier.aka.nice at gmail.com>> wrote:*
>>
>> Hi Tim,
>> Is it 5.3 or updated 6.0?
>>
>> Le dim. 8 mars 2020 à 07:10, tim Rowledge <tim at rowledge.org> a écrit :
>>
>>> Oh pooh.
>>>
>>> Download the release zip; extract, cd into the directory, run
>>> ./squeak.sh; boom.
>>>
>>> The image is fine and runs OK with a slightly older VM build
>>> (5.0-201912311458).
>>>
>>>
>>>
>>>
>>> tim
>>> --
>>> tim Rowledge; tim at rowledge.org; http://www.rowledge.org/tim
>>> Useful Latin Phrases:- Mellita, domi adsum. = Honey, I'm home.
>>>
>>>
>>>
>>> <>
>>
>>
>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.squeakfoundation.org/pipermail/squeak-dev/attachments/20200308/c1733477/attachment.html>


More information about the Squeak-dev mailing list