[squeak-dev] Trouble updating to Sista

Jakob Reschke forums.jakob at resfarm.de
Sat Mar 28 10:26:14 UTC 2020

Turns out CompiledBlock>>selector was another method that Scorching
shadowed. So the method was deleted when I unloaded Scorching, and
remained missing throughout the Squeak update because it has not

Also note that my working copy of Scorch was from March 2019, based on
the then-most-recent master version from March 2018. Maybe the
categories have been fixed in the meantime?

Am Sa., 28. März 2020 um 11:19 Uhr schrieb Jakob Reschke
<forums.jakob at resfarm.de>:
> For some reason CompiledBlock>>selector was not installed during the
> update. When I browsed the changes between my image and
> Kernel-eem.1319, it sat right there.
> Am Sa., 28. März 2020 um 10:54 Uhr schrieb Jakob Reschke
> <forums.jakob at resfarm.de>:
> >
> > Hello,
> >
> > I'd like to share my experience updating a Trunk image from
> > just-before-the-release to today's version. Maybe some of the points are
> > important outside of my box.
> >
> > First, the setting of the primary bytecode encoder was thwarted by one
> > single method in the Scorch tests. I had Scorch loaded because it was
> > my test subject for Tonel repositories. The setter method therefore
> > complained that both encoders were already in use (I don't remember the
> > exact message).
> >
> > So I tried to unload Scorch (package "Scorching" and associated). That
> > removed some important methods from my image, which left many of the
> > tools broken, including the debugger. The reason is that Scorching put
> > some method overrides in Context, but they were not in the category
> > *Scorcing-override, but just *Scorching. That's why they were removed
> > on unload. So I went to my loaded Kernel Monticello version and
> > restored the overridden methods from there, then unloaded Scorch. That
> > worked.
> >
> > After that, the Squeak update succeeded.
> >
> > But now I get a SubclassResponsiblity exception when #selector is sent
> > to a CompiledBlock in MorphicDebugger(Debugger)>>messageIconAt:. Now
> > going on to try debug this... It's hard because the image freezes
> > rather quickly, and needs much time until the user interrupt appers.
> > Move the pointer over a wrong spot and you get a hand full of new
> > debugger windows or the next freeze... First step: disabling the Show
> > message icons preference.
> >
> > Kind regards,
> > Jakob

More information about the Squeak-dev mailing list