[squeak-dev] GoferRepositoryError: can''t find EOCD position

David T. Lewis lewis at mail.msen.com
Thu Nov 26 14:12:03 UTC 2020

On Thu, Nov 26, 2020 at 10:19:16AM +0100, stes at PANDORA.BE wrote:
> I should mention that I'm doing this on a totally unsupported OS/Squeak version.
> Obviously https://github.com/Metacello/metacello/blob/master/.travis.yml
> mentions Linux and Squeak 5+ but I'm using Solaris 11 and Squeak 4.
> I wasn't aware of the package-cache directory, I moved it and tried again.
> But the same error ... 

It may help if you use the newer version of ZipArchive>>readFrom:
from newer Squeak images, and put that in your Squeak 4 image. This
will show (if possible) the name of the file or stream that had the
"cannot find EOCD position" problem.

Note, you can find this method by highlighting "EOCD position" in a
workspace, then search "method strings with it" which is hidden toward
the end of the menu options (so you may not have noticed it).


More information about the Squeak-dev mailing list