[squeak-dev] Squeak 6.0 alpha-20601 browsing revisions fails because of wrong class of requestor

Chris Muller asqueaker at gmail.com
Tue Aug 24 00:57:34 UTC 2021

Hi Tim,

> > I suspect some auto-magic(ally generated) stuff behind ServiceAction that makes 'browse revisions' fail in your image. It works fine in mine.

Is it possible, at one point, you accidentally clicked "Create new
service" at the top of the methods menu, quickly closed the debugger
it causes, forgot about it and moved on?  I've done that several
times and, I think, whenever I've found extra "Service" classes in my
image, that was the reason.  But I have no idea if it would cause the
symptom you're seeing.  Maybe check for any Service subclasses..

> > Which method did you try to browse revisions for?
> A variety, and mostly it either works or complains

In my trunk image, the one's I tried worked.  Which method(s) are you
seeing fail?

> about needing a Magma backed http repository (though it has failed there on a repo that is  on a squeaksource instance, so that seems dodgy)

that discrepency could be related to the GET vs. POST fix still
needing done.  If the method signature is really long, it might exceed
the url limit.

> OR it gets the dNU because the requestor returned by Project current world focusedRequestor is the default and not the browser's requestor - which implies to me some issue with the focus finding.

No idea.

More information about the Squeak-dev mailing list