[squeak-dev] cannot browse Monticello change from <working copy> to any of its ancestors

Marcel Taeumel marcel.taeumel at hpi.de
Tue Jan 5 12:13:13 UTC 2021

Hi Nicolas.

> I do not know if it was broken recently or if it never worked ...

Well, I always use the [Changes] button for that same result, never the history browser. See Monticello-mt.734 for an alternative to Monticello-nice.734.

Am 30.12.2020 10:12:13 schrieb Nicolas Cellier <nicolas.cellier.aka.nice at gmail.com>:
Hi MC experts,
when spawning history of a dirty package,
then selecting the <working copy>,
then trying to view changes from one of the ancestors via pop up menu,
the operation ends up with a 'MessageNotUnderstood: UndefinedObject>>snapshot'.

The problem is that:

^ self snapshotForInfo: self selectedInfo

will use a MCWorkingCopyAncestry as the selectedInfo...
But a MCWorkingCopyAncestry lacks essential messages of a regular MCVersionInfo, like versionName etc...
This will cause an Error, caught at upper level, and result in nil (no repository holds the 'working copy', there is no point in searching...).

I have no idea how to fix it, presumably we should catch early that we're dealing with 'working copy' and use appropriate snapshot for it...

I do not know if it was broken recently or if it never worked, but this is a useful feature when there are several ancestors, so help would be appreciated.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.squeakfoundation.org/pipermail/squeak-dev/attachments/20210105/666425d0/attachment.html>

More information about the Squeak-dev mailing list