[squeak-dev] Loading OMeta2 into Squeak 6.0Alpha?

Michał Olszewski m.olszewski at nexat.pl
Sat Jul 10 18:18:58 UTC 2021

(Oops, I didn't respond to list...)


Oh, that's not good. I'm still learning Squeak so I don't know much 
about internals so I can't help much here, but I will try my best.

I did some tests it seems like it's working in 5.3 but not in 6.0. Since 
I badly need some features of 6.0 (new functionality of FFI), I'd like 
to help fix it ASAP. So, here are the steps how to reproduce it:

On both 5.3 and 6.0 (20582) do the following:

 1. Load OMeta2Preload version 14
 2. Load (attached to this email) changeset that makes OMeta2Compiler
    methods compatible with current Compiler interface + reverts change
    made to CompiledMethod>>methodNode
 3. Do it (or print i) the following in a workspace: *OMeta2 match: 555
    with: #number *, or just any other example

Result: on 5.3 should've succeeded (or signal "match failed") with an 
output. On 6.0 will result 

Hope this somehow helps./

PS. I also tried to change superclass of OM2Fail to Error instead of 
Exception, to no avail/./
W dniu 2021-07-09 o 17:30, Marcel Taeumel pisze:
> Hi, there!
> Ah, might this be a new scenario for the recent changes in 
> context-unwinding in exception handlers?
> http://forum.world.st/Solving-multiple-termination-bugs-summary-amp-proposal-td5128285.html
> Hmm...
> Best,
> Marcel
>> Am 08.07.2021 14:24:09 schrieb Michał Olszewski <m.olszewski at nexat.pl>:
>> Hello,
>> I'd like to load OMeta2 package into Squeak 6.0 alpha (version 20582. 64
>> bit) but I'm having issue with that.
>> Attempting to load OMeta2.mcm results in
>> UndefinedObject>>findNextHandlerContextStarting (As result of
>> #OMeta2Fail). It seems like exception handling mechanism attempts to
>> access sender but the sender is nil. I tried also to load manually
>> OMeta2-Preload-hmm.14.mcz (which works), then OMeta2-Postload-hmm12.mcz
>> but the same error happens.
>> I recall, in Squeak5.3, this wasn't happening but further errors were
>> related with Compiler interface. I managed to fix that, by adding
>> Parser's method to #OMeta2Compiler. Unfortunalely there were even more
>> of these, which I could not fix.
>> Is there any way to make it work? The package works fine in Squeak 4.3
>> but I want to work in newer versions...
>> PS. The image is fresh, I didn't even use Preference Wizard. My OS is
>> Windows 8.1 64 bit.
>> Michał
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.squeakfoundation.org/pipermail/squeak-dev/attachments/20210710/ac037b77/attachment.html>

More information about the Squeak-dev mailing list