[squeak-dev] A case where Morph copying fails

karl ramberg karlramberg at gmail.com
Fri Aug 12 18:26:21 UTC 2022

Weird bug.
I got a DNU once, and looked at the issue in the debugger.
I tried a second time and now I can't reproduce it.
Is there some state in the image that is not initialized ??

Side note: A holder can only be found in Supplies flap as far as I know.
To test the issue one must show the Supplies flap.


On Thu, Aug 11, 2022 at 5:10 PM Tim Johnson <digit at sonic.net> wrote:

> Hi all,
> Fresh 6.0 image --
> 1) drag out a Holder from Supplies flap
> 2) drag out a Rectangle from Supplies flap
> 3) drop Rectangle into Holder  (note the Rectangle border becomes
> extra thick)
> 4) open a Halo over the Holder
> 5) try to click on the Green "copy/duplicate" button
> 6) get a DNU/MNU: MorphicModel1(Object) doesNotUnderstand:
> #copyUniClassWith:
> Last time I tried this, it actually behaved differently.  It was more
> like this:
> 1) Drag out a Holder
> 2) Drag out a Rectangle
> 3) Drop the Rectangle into the Holder
> 4) Copy the Holder using the Halo green copy/duplicate (this would work)
> 5) change the color of the embedded Rectangle via its inspector
> 6) Try to copy the Holder now (this would fail, again via #veryDeepCopy)
> It's also a little strange that the first Rectangle dropped into the
> Holder sees its border become thicker, while a second / third
> Rectangle do not see their border width change.
> Thanks,
> Tim
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.squeakfoundation.org/pipermail/squeak-dev/attachments/20220812/3135bd4d/attachment.html>

More information about the Squeak-dev mailing list