[squeak-dev] DoItFirst | How to compile anything?

Marcel Taeumel marcel.taeumel at hpi.de
Mon Jan 24 15:56:18 UTC 2022

Okay, I solved it by first inspecting the process that had the endless recursion:

[ [ 500 milliSeconds wait. FileStream stdout nextPutAll: ((Processor preemptedProcess suspendedContext stackOfSize: 10) joinSeparatedBy: String cr) ] repeat ] forkAt: 45

Priority 75 was my first try put that just interrupted the EventTickler. :-)

Then I saw information about the cause if the issue and first I wanted to install/compile a different method, but it turns out that "Behavior >> #compile:" does not work from within DoItFirst without more setup. So I tried to directly modify that broken state directly. It were just some dictionaries involved at #at:(put:) worked like a charm. :-)

... maybe I should have tried #compileSilently:? Hmm...

Am 24.01.2022 16:10:29 schrieb Marcel Taeumel <marcel.taeumel at hpi.de>:
Hi all --

I have to rescue an image asap. How to use "--doit" to compile a method? I keep on getting an "MessageNotUnderstood: UndefinedObject>>position" error... :-(

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.squeakfoundation.org/pipermail/squeak-dev/attachments/20220124/82875654/attachment.html>

More information about the Squeak-dev mailing list