[squeak-dev] Glorp

Jörg Belger unique75 at web.de
Fri Jan 28 18:01:25 UTC 2022


Can someone tell me WHAT I have to load from WHICH repository and WHAT I need to execute in workspace to get a running and working Glorp in Squeak on macOSX, maybe at first with a simple sqlite3 database.

What I did the last weeks is to get a running OpenDBX installation first, but without success. Here is what I did:

- install OpenDBX with „brew install opendbx"

- load „ConfigurationOfOpenDBXDriver“ from the already existing repository  http://www.squeaksource.com/MetacelloRepository <http://www.squeaksource.com/MetacelloRepository> from Monticello Browser
- execute in workspace „ConfigurationOfOpenDBXDriver project latestVersion load“
- open test runner and run the OpenDBX tests
- it says me that there is a „Bad Function address“

- I tried many things to add the symlink „opendbx“ into the app resources folder
- I tried to use „libopendbx“ and other names
- nothing was working

Later I found that the FFI package is outdated and I loaded a version from 'http://source.squeak.org/FFI‘

- i executed "Metacello new configuration: ‚FFI'; load.
- all the other things on the website are not working, you get always loading errors or dependency errors

With that FFI I get now the error „no module to load address from“

There are so much loading and dependency problems with other packages. Often the configurations contains the class method #ensureMetacello, but with an outdated url seaside.gemstone.com <http://seaside.gemstone.com/> instead of seaside.gemtalksystems.com <http://seaside.gemtalksystems.com/>.

So this is simply a mess for me as a Squeak beginner, when nothing is loadable and working and when dependencies to other repositories exists, that are simply outdated.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.squeakfoundation.org/pipermail/squeak-dev/attachments/20220128/353859ed/attachment.html>

More information about the Squeak-dev mailing list