New VMMaker/svn release

David T. Lewis lewis at
Fri Dec 30 17:59:36 UTC 2005

On Thu, Dec 29, 2005 at 12:55:03PM -0800, tim Rowledge wrote:
> On 29-Dec-05, at 12:00 PM, David T. Lewis wrote:
> >
> > Unfortunately I have not been able to build a working 64 VM yet.
> > I'm using VMMaker-tpr.39 (loaded from Squeak Map), SVN 1282, plus my
> > local patches (attached for reference). The OS is 32 bit Intel Linux.
> >
> > I was previously able to build a 64 bit VM with VMMaker-tpr.37 and
> > SVN 1259, with the same local patches.
> Hmm, sadly not something I can be of much help with; no linux machine  
> etc.
> All I can say is that *very* little changed between .37 and .39 that  
> I could imagine having any such effect. Um, well diff is your  
> reasonably polite acquaintance I think.

Well, there was not much you could have done to help me short of
offering a brain transplant. I just had my plugin path screwed
up and was accidentally loading a 32 bit display module with a
64 bit VM. Sorry about that.

So, back to the matter at hand. I've tested the new VMM with no
problems on:

- 32 bit Intel, Linux, 32 bit VM
- 32 bit Intel, Linux, 64 bit VM
- 64 bit AMD Turion, 64 bit Linux, 64 bit VM
- 64 bit AMD Turion, 64 bit Linux, 32 bit VM

The tests were done with VMMaker-tpr.39, SVN 1282, and the patches
that I attached to my earlier message.

I did spot one issue that I had not previously noticed. With the
combination of 64 bit machine and 32 bit VM, the memory access
inline functions in sqMemoryAccess.h work fine, but the macros
do not work. This is not related to my patch for sqMemoryAccess.h,
since I tried building with the original version and running with
no display, and still fail in a longAtput() macro.


More information about the Vm-dev mailing list