[Vm-dev] Link error

Igor Stasenko siguctua at gmail.com
Sat Apr 26 17:20:17 UTC 2008

2008/4/26 Gwenaël Casaccio <mrgwen at gmail.com>:
>  I've tried to regenerate the entire code but I've got the same error :
>  gcc -mwindows -o ./obj/vm/Squeak.exe ./obj/vm/sqWin32Alloc.o ./obj/vm/sqWin32Arg
>  s.o ./obj/vm/sqWin32DirectInput.o ./obj/vm/sqWin32Directory.o ./obj/vm/sqWin32Ex
>  ports.o ./obj/vm/sqWin32ExternalPrims.o ./obj/vm/sqWin32GUID.o ./obj/vm/sqWin32I
>  ntel.o ./obj/vm/sqWin32PluginSupport.o ./obj/vm/sqWin32Prefs.o ./obj/vm/sqWin32S
>  ervice.o ./obj/vm/sqWin32Stubs.o ./obj/vm/sqWin32Utils.o ./obj/vm/sqWin32Window.
>  o ./obj/vm/version.o ./obj/vm/sqNamedPrims.o ./obj/vm/sqVirtualMachine.o ./obj/v
>  m/Squeak.exp ./obj/vm/resource.o  -lddraw -ldinput -lopengl32 -lwsock32 -lcomdlg
>  32 -lole32 -lwinmm -lversion -luser32 -lgdi32 -lkernel32 -lcrtdll
>  ./obj/vm/sqWin32Args.o: In function `IsImage':
>  //C/SqueakVM/platforms/win32/build/../../win32/vm/sqWin32Args.c:26: undefined re
>  ference to `sqImageFileOpen'
>  //C/SqueakVM/platforms/win32/build/../../win32/vm/sqWin32Args.c:28: undefined re
>  ference to `sqImageFileRead
>  ...
The make file in platforms/win32/build/ is outdated. I tried to build
using it , but it looks like totally broken.
I'm using makefile in winbuild dir (located at same level as plaforms subdir).
And before building, don't forget to point VMMaker to winbuild/src  dir.

>  Gwenael Casaccio

Best regards,
Igor Stasenko AKA sig.

More information about the Vm-dev mailing list