[Vm-dev] UUID new crashes 64bit vm

Philippe Marschall philippe.marschall at gmail.com
Mon Oct 6 04:39:07 UTC 2008

2008/10/6, David T. Lewis <lewis at mail.msen.com>:
> On Sun, Oct 05, 2008 at 09:05:29PM +0200, Philippe Marschall wrote:
>> 2008/10/5, David T. Lewis <lewis at mail.msen.com>:
>> >
>> > On Sun, Oct 05, 2008 at 04:07:12PM +0200, Philippe Marschall wrote:
>> >>
>> >> I built a 64bit VM (for 32bit images) from SVN trunk and
>> >> VMMaker-dtl.102. UUID new causes the VM to segmentation fault. The
>> >> reason I did this is because I need to have a Unix VM with the cUrl
>> >> plugin and my system is 64 bit. I need to have the cUrl plugin because
>> >> I need an https client. If I'm doing it wrong what would be the right
>> >> way of doing it? Or is there even a recent 64bit Unix VM available
>> >> that was a cUrl plugin?
>> >
>> > Some plugins have not been updated for 64bit platforms. The CurlPlugin
>> > may be one of them.
>> The CurlPlugin runs fine. It's the UUIDPlugin I have trouble with.
> I just tried building the UUIDPlugin on 64bit AMD and it works fine.
> I ran it under gdb and stepped through the primitive just to be sure
> it was running, and there were no problems.
> Perhaps there is a problem with your libuuid installation? I installed
> only the 64bit uuid library (usr/lib64/libuuid.so) when I tried this.

Same here.

> Perhaps if the 32bit library is also installed, it could cause confusion.

Indeed there is usr/lib32/libuuid.so as well. How should I proceed?


More information about the Vm-dev mailing list