[Vm-dev] Re: [Pharo-project] GZipWriteStream crashing my VM when serializing ?

David T. Lewis lewis at mail.msen.com
Sat Dec 10 16:34:08 UTC 2011

On Sat, Dec 10, 2011 at 03:58:29PM +0100, Mariano Martinez Peck wrote:
> On Sat, Dec 10, 2011 at 2:16 AM, David T. Lewis <lewis at mail.msen.com> wrote:
> > This looks like a nasty bug in the plugin, but I cannot reproduce it.
> > I have Fuel loaded in my Squeak image running on Linux, and I ran
> > FLMethodContextSerializationTest>>testMethodContextThisContext without
> > a crash. I tried it on both Cog and a standard VM, and did not get
> > a crash in either case. The test fails (probably for some Squeak/Pharo
> > issue)
> > but it gets through the serialize/materialize part of the test without
> > any problem.
> >
> > Am I perhaps running a different version of Fuel that does not
> > exercise the ZipPlugin in the same way?
> >
> >
> Yes, exactly. Sorry for not saying that before. If you want to reproduce
> it, you must also install the package FuelCompression and then change
> FLSerializationTest >> #setUp  to send the message #useGzipInMemoryStream
> rather than #useStandardFileStream. Now if you run
> #testMethodContextThisContext it would do it using a GZip stream.

I loaded this in my Squeak image on Linux and can now confirm the
crash for both Cog and standard interpreter VM.


More information about the Vm-dev mailing list