[Vm-dev] building Cog

Igor Stasenko siguctua at gmail.com
Fri Jul 8 04:36:37 UTC 2011

On 8 July 2011 06:26, JJ Stevens <jjstvns at gmail.com> wrote:
> This is a nightmare.  It is as bad as installing unix with apt.  Why can't I have one tarball or one installer exe for everything?  Can't use msysGit, which I tried originally since I have about 18 months experience using it, since it only has the minimal binaries to compile git, not what is needed for Cog it seems.
> Installing MSYS/MinGW is a complete disaster.
> It looks like there are a few problems MSYS install instructions (http://www.mingw.org/wiki/msys).
> The first step talks about installing MinGW:
> If you haven't already installed MinGW on your system, install MinGW in C:\MinGW. It is better to not install it in the same directory than MSYS, though there should be no problem since MSYS 1.0.11. In the installer, choose "Download and install", then "Current" (it will install gcc 4.4.0).
> Following the MinGW link takes me to the MinGW sourceforge site, click files, and which MinGW installer is there??  The only one I find is: http://sourceforge.net/projects/mingw/files/Automated%20MinGW%20Installer/mingw-get-inst/mingw-get-inst-20110530/mingw-get-inst-20110530.exe/download.  This does NOT have install options for "Download and install" and "Current".  However, I get a MinGW directory with a bin with gcc and g++.  Looks like this file was changed on 5/30/2011.
> The second step looks good.
> The third step refers to a post-install process question that does not appear for me.
> The fourth step is golden, except the second step already provided an option to install the DTK.
> The fifth step, install MSYS Core 1.0.11 has the wrong link.  The correct link is: http://sourceforge.net/projects/mingw/files/MSYS/BaseSystem/msys-core/msys-1.0.11/msysCORE-1.0.11-bin.tar.gz/download.  Furthermore, it overwrites stuff from the second link and it has like 6 subsequent versions from 1.0.11.
> Without installing step 5, I get the same results as with my original msysGit attempt, undefined references due to missing libraries.  With step 5 I cannot even compile past the first plugin object compile: UUIDPlugin, because of a missing libgmp-10.dll.  I tried to dig into CMake files to find a LIB reference, and got into the deep weeds.
> Could someone who knows what they are doing try this all from scratch and update the instructions, please?   There are just too many moving pieces and a tarball along the lines of 'Squeak-Win32-Tools-1.2.zip' would be a blessing.
> jj
Last time i installed it, i used automated installer:

for git i just followed what was on their wiki page
and then added path to <where is git>/bin to the PATH variable.

if you fail, i think it worth asking on msys mailing list, how to
install it correctly, because its really confusing.
Best regards,
Igor Stasenko AKA sig.

More information about the Vm-dev mailing list