[Vm-dev] Re: [squeak-dev] Problem with SerialPort and Cog

Esteban Lorenzano estebanlm at gmail.com
Sun Apr 7 09:35:05 UTC 2013

Hi Eliot, 

we solved that (for mac) in our branch:

(we use same file for build mac and unix, see "BUILD_FOR_OSX" definition)

I think the old sources for windows should work (at least we didn't changed that, but didn't tested either :S)


On Apr 7, 2013, at 2:11 AM, Eliot Miranda <eliot.miranda at gmail.com> wrote:

> On Fri, Apr 5, 2013 at 2:37 PM, Javier Diaz-Reinoso <javier_diaz_r at mac.com> wrote:
> On 03/04/2013, at 10:53, Javier Diaz-Reinoso <javier_diaz_r at MAC.COM> wrote:
> > After line: p openPort: '/dev/cu.usbmodem1a21'., p in Cog is:
> >       SerialPort(closed, 115200 baud, 8 bits, 1 stopbits, no parity)
> > is closed because port is nil, in Squeak 4.2.5beta1U is:
> >       SerialPort(#'/dev/cu.usbmodem1a21', 115200 baud, 8 bits, 1 stopbits, no parity)
> > port is: '/dev/cu.usbmodem1a21'.
> >
> > I repeated my test with a virgin copy of Squeak4.4-12327 (before I was using 4.1 and 4.3), also with other macbook pro, the same error.
> >
> [cut...]
> Well, I download the VM from www.squeakvm.org/svn/squeak/branches/Cog/ and find that primitiveSerialPortOpenByName is not defined!.
> In /Tools/Squeak/VMCog/platforms/unix/plugins/SerialPlugin/sqUnixSerial.c (included in the CoreVM. xcodeproj) the function serialPortOpenByName is defined, but is not "linked" with primitiveSerialPortOpenByName so the call (in Squeak) of primOpenPortByName: fail.
> Ah, right.  That's because there is no support on Mac OS or Windows.  So wen I tried adding  primitiveSerialPortOpenByName it broke the builds on Windows and Mac.  If anyone has support files for those platforms I'll try again.
> -- 
> best,
> Eliot

-------------- next part --------------
Skipped content of type multipart/mixed

More information about the Vm-dev mailing list