[Vm-dev] Pi vm builds need a priority checker applet

Fabio Niephaus lists at fniephaus.com
Thu Aug 18 16:39:26 UTC 2016

On Thu, Aug 18, 2016 at 1:00 AM tim Rowledge <tim at rowledge.org> wrote:

> > On 17-08-2016, at 3:34 PM, Fabio Niephaus <lists at fniephaus.com> wrote:
> >
> >
> > On Thu, Aug 18, 2016 at 12:17 AM tim Rowledge <tim at rowledge.org> wrote:
> >
> > A persistent problem with the PI vm is that users of xrdp need to wrap
> the start-up in ‘sudo -E’ because.. well, never mind, unix is just plain
> stupid. Whatever the issue, we can test for the problem of needing to use
> sudo by running a trivial test program in the shell script; all it does is
> try changing a thread priority and returns whether it worked or not.
> >
> > Just to make sure: it is not enough to create a squeak.conf as describe
> at [1] and reboot?
> Unfortunately that doesn’t work when using xrdp for your remote display.
> It’s not even a strictly squeak issue - some googling will reveal a
> depressingly long list of problems to do with the same error. The Raspbian
> kernel; has no problems at all with squeak when using a direct display. It
> doesn’t have this particular problem with vnc - but it *does* have a fatal
> problem with trying to use the composition input window calls. Again, not a
> specifically squeak, raspbian nor ARM issue but a generic bit of nastiness
> in linux.
> > Could you please give [2] a try on a raspi? Feedback is more than
> welcome as we are about to release Squeak 5.1 very soon.
> As long as it’s made from the very latest source Eliot put out today it
> will be ok. *Except* I note that the HostWindowPlugin is missing from the
> plugins/int file in build.linuxARMv6/squeak.cog.spur and in fact after a
> quick look it is missing form all the linux related build directories that
> I checked. Whilst the plugin is not complete it does provide support for
> title and size aspects and so I’d recommend including it.
> 5.1 will be the basis of the next Pi Scratch release so I have several
> millions of reasons to help getting it right...

Shall we just open the vm with `sudo -E` on ARM platforms in the 5.1
release? This seems to be a reasonable solution for now. Usually, a user
will be prompted to enter a password and we can explain why. Once we figure
out a better solution, we can iterate :)

BTW: There's going to be an ARM-only bundle for the Squeak 5.1 release as


> tim
> --
> tim Rowledge; tim at rowledge.org; http://www.rowledge.org/tim
> Don't sweat petty things....or pet sweaty things.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.squeakfoundation.org/pipermail/vm-dev/attachments/20160818/f8bea6a9/attachment.htm

More information about the Vm-dev mailing list