[Vm-dev] buildspurtrunkvmmakerimage.sh fails on Mac

Nicolas Cellier nicolas.cellier.aka.nice at gmail.com
Fri Aug 19 20:30:30 UTC 2016

yes, this is a problem I encountered both in 32 and 64 bits squeak while

I think it's related to showing the progress bar while updating the
progress bar.
It's a Squeak trunk update problem, not a VM problem.

If some class layout change, but some block is still active (yeah, did you
see how many blocks we traverse just to change display of a bar...), then
the old block has invalid inst var offsets (offsets to the old object that
now has become a new object with new layout).

In an interactive image, just close the debugger and relaunch the update.
In an headless automated process, well... We should have fixed the update
or start from a newer artifact...

2016-08-19 21:32 GMT+02:00 tim Rowledge <tim at rowledge.org>:

> I just tried running the vmmaker-build script on my iMac with weirdly bad
> results.
> The vm it downloads is the CogSpur.app-16.18.3692 version. Whilst trying
> to do the update part of the process I had several *very* odd failures
> where an object in a block was mistaken for nil during a message send. For
> example in a progress bar update (which I can’t provide a log for since the
> log got overwritten later) a line
> (bars at: index)
> lead to a nil is not indexable halt. Yet in inspecting the prior
> stackframe the bars object was a perfectly normal array of progress bars. A
> similar but not identical problem happened during another attempt.
> Attempting to filein the BuildSqueakSpurTrunkVMMaker.st file failed when
> the vm exploded with no visible log.
> Now I’m attempting to repeat that with a new 5.1rc1 vm & already up to
> date 5.1rc1 image. Which has sorta-worked, in a rather odd manner. It got
> to the final save and quit but when I start the supposedly prepared image
> there is a problem with it trying to filein that file. I can’t tell right
> now if it relates to the manual filein I started or if something got added
> as a deferred action? Or maybe it’s a side-effect of the filein having a
> save & quit? Not come across this before.
> So far as I can tell it did complete the filein, so maybe all is well.
> tim
> --
> tim Rowledge; tim at rowledge.org; http://www.rowledge.org/tim
> Strange OpCodes: BOMB: Burn Out Memory Banks
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.squeakfoundation.org/pipermail/vm-dev/attachments/20160819/d5214ec9/attachment-0001.htm

More information about the Vm-dev mailing list