[Vm-dev] Rebuilding configure script for linux vm

tim Rowledge tim at rowledge.org
Thu Oct 27 21:55:44 UTC 2016

I’m trying to make the UnicodePlugin for an x86 linux. You’d think that would be simple enough but in fact the config fails because it has a hard-coded ARAM path in the UnicodePlugin/acinlude.m4 file - probably my fault from a couple of years ago as it happens.

So, add the x86 path (for the glibconfig.h file; I imagine there is a way to make that get worked out automagically - see the CPPFLAGS line in platforms/unix/plugins/UnicodePlugin/acinclude.m4) and rebuild. Except the mvm script doesn’t re-run the configuration build. OK, delete the dratted config.h to force it to re-run autoconf.

Sigh, nothing doing. No change.

Look in platforms/unix/config and try `make`. Fails at configure.ac line 201. Which is weird because it *must* have worked not so many hours ago when I did a completely scratch load of the source tree on this particular machine.

Suggestions welcomed.

Error output follows - 

tim at ubuntu:~/squeak/opensmalltalk-vm/platforms/unix/config$ make configure
./mkacinc > acplugins.m4
	+ ../vm-display-Quartz/acinclude.m4
	+ ../vm-display-X11/acinclude.m4
	+ ../vm-display-custom/acinclude.m4
	+ ../vm-display-fbdev/acinclude.m4
	+ ../vm-sound-ALSA/acinclude.m4
	+ ../vm-sound-MacOSX/acinclude.m4
	+ ../vm-sound-NAS/acinclude.m4
	+ ../vm-sound-OSS/acinclude.m4
	+ ../vm-sound-Sun/acinclude.m4
	+ ../vm-sound-custom/acinclude.m4
	+ ../vm-sound-null/acinclude.m4
	+ ../vm-sound-pulse/acinclude.m4
	+ ../vm/acinclude.m4
	+ ../plugins/B3DAcceleratorPlugin/acinclude.m4
	+ ../plugins/BitBltPlugin/acinclude.m4
	+ ../plugins/BochsIA32Plugin/acinclude.m4
	+ ../plugins/BochsX64Plugin/acinclude.m4
	+ ../plugins/FloatMathPlugin/acinclude.m4
	+ ../plugins/GdbARMPlugin/acinclude.m4
	+ ../plugins/IA32ABI/acinclude.m4
	+ ../plugins/MIDIPlugin/acinclude.m4
	+ ../plugins/Mpeg3Plugin/acinclude.m4
	+ ../plugins/PseudoTTYPlugin/acinclude.m4
	+ ../plugins/UUIDPlugin/acinclude.m4
	+ ../plugins/UnicodePlugin/acinclude.m4
	+ ../plugins/UnixOSProcessPlugin/acinclude.m4
	+ ../plugins/XDisplayControlPlugin/acinclude.m4
configure.ac:201: error: possibly undefined macro: AC_PROG_NM
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
configure.ac:219: error: possibly undefined macro: AC_DISABLE_STATIC
configure.ac:220: error: possibly undefined macro: AC_PROG_LIBTOOL
make: *** [configure] Error 1

tim Rowledge; tim at rowledge.org; http://www.rowledge.org/tim
Original Sin is hard to find, but the digitally enhanced version is readily available.

More information about the Vm-dev mailing list