[Vm-dev] VM building on Pi, OpenGL libraries and other fun things

tim Rowledge tim at rowledge.org
Thu Aug 10 02:13:51 UTC 2017

Further info on this afpfs thing - 

> Bascially
> `sudo apt-get install afpfs-ng`
> `mkdir mymountpoint`
> `chmod og-rwx mymountpoint`
> `mount_afp afp://username:password@macnameorip/targetdir mymountpoint`
> or to be more literal
> mount_afp afp://fred:flintstone@fredMac/squeakdev /home/pi/squeakdev
> It works with FUSE, so maybe you want to install that too.

Well, trying to add it to my /etc/fstab has been… annoying. It’s not just me, since I’ve found perhaps several hundred web hits from people having a hard time with it. The first part of the problem is that the purported fstab line to use is of the form 
(from https://sites.google.com/site/alexthepuffin/home by the author)
"afpfs#afp://username:mypass@ /tmp/xa20 fuse user=adevries,group=fuse 0 0 “

BUT this prevents the Pi from booting. Urk. By sheer fluke I was doing this test on a Pi that is set to boot from a usb disk so it was reasonably easy to mount it on another Pi and eventually I worked out how to find the fstab and comment out that line. I tried rebooting and then re-enablgin the line and using `sudo mount -a` to see what happens and apparently there was no `afpfs` command; after more fun time googling I discovered this was supposed to be  bash script `/sbin/afpfs` that moves around the arguments (why? why ever do them in a different order to the main command?) and then I discovered a page from a Pi book that google had scanned which mentioned manually creating this file. Huh? Not included in the install package?

OK, make the script as shown (and eventually found in the source code for the thing) and try that. Nope, refuses to boot, so redo the cross-mounting and modify fstab, again. You get the general gist of it; many hours spent searching, trying ideas suggested by people having related issues, rebooting and so on. I did finally find a version of the fstab line that does allow the boot to complete, albeit very, very, slowly and without actually making the mount available -

afpfs#afp://username:password@TCname.local/sharename /mountpoint fuse user=osmc,group=fuse,x-systemd.automount,noauto 0 0

So right now I’m stuck and annoyed and frustrated. This isn’t how things should work but seems to have become the standard over the last years. Grrr. Suggestions for solutions welcomed. 

tim Rowledge; tim at rowledge.org; http://www.rowledge.org/tim
Strange OpCodes: CCP: Clear Core and Proceed

More information about the Vm-dev mailing list