[Vm-dev] [OpenSmalltalk/opensmalltalk-vm] Trouble running OSVM in an Ubuntu 20/aarch64 docker (raspi) (#544)

Christoph Thiede notifications at github.com
Wed Dec 30 17:44:45 UTC 2020

I have tried my luck now with `squeak.cog.spur_linux32ARMv6_202003021730`, but I keep getting the same error message. A docker container will always use the same architecture/bitness as the host system, won't it?
I am a bit confused: From my Windows Subsystem for Linux (x64), I am used to seeing some kind of "cannot execute binary file: Exec format error" messages if I run a 32-bit application so the bitness does not match. Why don't I see errors like this in my docker container? It looks as if the VM executable itself can be run.

> Note that you probably need some libraries, too, because the VM is for the Raspberry-Pi 2 and 3 compatible ARMv6 instruction set (which is a 32-bit one) so you might need some multi-arch support in ubuntu.

Can you give me a pointer on how to find these libraries?

I also tried to compile `linux64ARMv8` manually, but how can I cross-compile this from my Intel x64 Ubuntu system? The mvm script terminates with: "configure: error: C compiler cannot create executables" and `config.log` contains "cc1: error: bad value ('armv8-a') for '-march=' switch". The internet says I should use `aarch64-linux-gnu-gcc` or `arm-linux-gnueabi-gcc` (not sure which) instead of `gcc`, but how can I tell mvm to use this? 🤯 

You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.squeakfoundation.org/pipermail/vm-dev/attachments/20201230/72239117/attachment.html>

More information about the Vm-dev mailing list