[Vm-dev] [OpenSmalltalk/opensmalltalk-vm] How to build on Win32 using WSL/Ubuntu | Missing headers (#510)

Eliot Miranda eliot.miranda at gmail.com
Tue Jul 7 07:47:19 UTC 2020

Hi Christoph,

> On Jun 13, 2020, at 11:07 AM, Christoph Thiede <notifications at github.com> wrote:
> Hi Marcel,
> WSL = Windows Subsystem for Linux?
> https://en.wikipedia.org/wiki/Windows_Subsystem_for_Linux
> Exactly. :-)
> I tried installing Cygwin now, too, but I still do not succeed.
> I ran scripts/installCygwin.bat, then started a Cygwin session and ran the mvm script from there. But still, Windows.h is not found. Is this what I am supposed to do?
> However, I tried MSVC, too (this would be my preferred way over Cygwin). So, again strictly following the HowToBuild file, I opened an x86 Native Tools Command Prompt, navigated to build.win32x86\squeak.cog.spur\, executed ..\common\SETPATH.BAT and finally ..\common\MAKEDEBUG.BAT. Now guess what type LOGD will give me?
> ../../platforms/win32/vm/sqWin32Utils.c:11:10: fatal error: Windows.h: No such file or directory
> So I guess the HowToBuild instructions much miss some significant point on how to these headers ... :-(

Did you install an SDK?  I’m pretty sure that’s where the Windows.h headers live.  Instal a 10.x SDK if you haven’t already.
> Best,
> Christoph

_,,,^..^,,,_ (phone)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.squeakfoundation.org/pipermail/vm-dev/attachments/20200707/f1997a51/attachment.html>

More information about the Vm-dev mailing list