[Vm-dev] Building Ubuntu x64 vm; did I drop a clang-er?

tim Rowledge tim at rowledge.org
Thu Apr 1 20:16:02 UTC 2021

For reasons, I tried compiling a Ubuntu cog/spur/x64 vm yesterday. It hasn't been very successful thus far.

First problem was that it simply wouldn't compile *anything* according to the config log. The system has the usual gcc stuff, so I was a bit surprised. It appeared to want 'clang' which I've never needed to take note of before; so I installed it - what could go wrong, eh? Is this an expected thing? Is it just another infuriating bit of Ubuntuism?

After that it did a build but we seem to be suffering two somewhat familiar problems;

 - our old friend
"/usr/include/glib-2.0/glib/gtypes.h:32:10: fatal error: 'glibconfig.h' file not found"
appeared and again it is the architecture specific path in platforms/unix/plugins/UnicodePlugin/acinclude.m4 not being there. I have now tried manually adding the extra include path "/usr/lib/x86_64-linux-gnu/glib2.0/include" to the acinclude.m4 and even the Makefile.inc and it *still* doesn't appear in the cmdline used to make the plugin test - so no plugin is made. I'd swear that was enough when building it for AARM64 a few months ago? Damned autoconf...

- the rtprio stuff, yet again. One can add the squeak.conf file do the reboot and ... no change. If I actually run the vm with sudo there are no complaints but that isn't really very practical. Annoyingly this seems to be sometihng that is not 'reliable' - a colleague with the same version of Ubuntu installed simply changed the permissions to 755 (which I've tried too) and it was fine.

tim Rowledge; tim at rowledge.org; http://www.rowledge.org/tim
Cashtration (n.): The act of buying a house, which renders the subject financially impotent for an indefinite period.

More information about the Vm-dev mailing list