[Vm-dev] regression: TestObjectsAsMethods crash in 4.19.5 (not in 4.16.7)

David T. Lewis lewis at mail.msen.com
Thu Mar 18 00:02:52 UTC 2021

Hi David,

Sorry I did not reply earlier,

On Sun, Mar 14, 2021 at 07:30:25PM +0100, stes at PANDORA.BE wrote:
> > A trivial fix is to rearrange some primtive number assignments, but the
> > correct thing to do is adopt the logic that Eliot uses in oscog so that
> > the function is not invoked as a "primitive" at all.
> >
> > I'll try to follow up on this next week. 
> Would it please be possible to commit to subversion the trivial fix,
> while waiting for the correct fix.

Unfortunately no. I tried reassigning primitiveInvokeObjectAsMethod to
an unused primitive number. That worked fine, but I quickly found that
more recent versions of Squeak trunk were using that "unused" primitive
number for some other purpose, so this is a no-go.

A quick and dirty fix is not feasible, it needs to be done right. That
means adapting or adopting Eliot's implementation.

      Numbered primitives are a plague and a pestilence. Please just stop doing that.


More information about the Vm-dev mailing list