[Newbies] Need help with figuring out how to incorporate SqueakSSL + WebClient into Etoys

Steve Thomas sthomas1 at gosargon.com
Sun Apr 17 01:12:24 UTC 2011

So I found Andreas's post on Installing SqueakSSL with Seaside
figured I would try it in Etoys (realizing it may not work).

I tried:

(Installer ss)
project: 'SqueakSSL';
install: 'SqueakSSL-Core';
install: 'SqueakSSL-Tests';
project: 'WebClient';
install: 'WebClient-Core';
install: 'WebClient-Tests';
install: 'WebClient-Seaside'.

But Installer was not defined in Etoys.

I tried using the "SqueakMap Package Loader" in Etoys, but got a message
saying "The SqueakMap master server is running version 2.3 and the client is
2.0, You need to upgrade" I clicked yes, I got an exception.

So I tried to load the .mcz files in the order listed by dragging them onto
the Etoys image and selecting "load version".  This worked fine
for SqueakSSL-Core, but when I tried to load SqueakSSL-Tests, I got an
exception (below), the key error (as far as I can tell) is

Receiver: Warning: This package depends on the following classes:

So from some more searching it seems TestCase is defined in SUnit (makes
sense) but when I browse the SUnit in Etoys, I only see TestCaseDebugger
(ie: no Test Case).  So I went to SqueakSource and loaded the latest SUnit
package (SUnit-NialRoss.40.mcz, didn't bother with the GUI, for now, let me
know if I should).  Once I load the new SUnit, SqueakSSL-Tests loads fine.

I then was able to load WebClient-Core and WebClient-Tests.

Now, how do I run the tests?
Also, is this the correct approach? (ie: did I load the correct things or am
I missing something?)

My end goal is to allow kids to post to Google Blogs from within Etoys.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.squeakfoundation.org/pipermail/beginners/attachments/20110416/e41181c9/attachment.htm

More information about the Beginners mailing list