[Seaside] headless squeak problem

Dmitry Dorofeev dima-sender-3c337a at yasp.com
Wed Nov 16 17:29:57 CET 2005

Hello all

I've created a nice image with my Seaside project and RFB.

On remote host after start i see seaside app, but not RFB.
It does not listen to RFB port at all.

So i added liveWeb and REPLServer, uploaded to remote server and managed to
create gif images of the World with:

 GIFReadWriter putForm: Display onFileNamed: 'screenshot.GIF'

And I sow a message, that Squeak can not find sources file named /blah/blah/

That is VERY strange, as the SqueakV3.sources sits there under name shown
in the message. With liveWeb i can even see the sources file and read it!

FileList2 openMorphicViewInWorld

Finally I managed to start RFB from liveWeb with
RFBServer menu openInWorld
and clicking in menu

and even saved an image with
SmalltalkImage current saveSession.

But saved image did not start RFB complaining about missed sources file!

It is so misterious i have no ideas left in my head.

The only possible problem i can see is that i run it under FreeBSD5.4 amd64,
but squeak is compiled on FreeBSD5.4 i386
so I run 32bit executable under 64bit OS (which is claimed as supported)
BTW seaside app works as expected

Could anybody put some light on this issue please ?


More information about the Seaside mailing list