[Seaside] Gemstone / Magritte
ramon.leon at allresnet.com
Tue Aug 7 19:40:15 UTC 2007
> > It should be fixed in Gemstone as well as Magritte, though
> I've long
> > since worked my way around the latter because I don't see it
> > happening.
> Did you ever think that a selector name choice might turn
> into a nightmare 4 years later?
Well, this issue has certainly made me think carefully about introducing
extension methods and how they're named, for sure. But I have been
mentioning it for about 2 years. Not that it bothers me too much, I
maintain my local port with #descriptor and happily use #description all
over my domain classes for a description string.
> Magritte did not start as a
> framework, but evolved from a couple of helper classes in
> SmallWiki. It is clear that any selector name potentially
> leads to conflicts. I agree that #descriptor would have been
> a slightly better, but the fact that I know a couple of
> packages that implement #descriptor is not really motivating
> me to make that change.
Understandable, have you considered whether there'd actually be collisions
with those other packages in actual use? Glorp and OmniBrowser use it, but
not in a way that'd collide with Magritte, what other packages do you know
> I doubt that this has anything to do with the language the
> users are speaking. Most people write their application in
> english anyway.
You're right, but they don't always use English idioms. You're a good
example, I've tripped over a selector or two of yours before like
beEphemeral, perfectly valid, but it doesn't feel idiomatic to me, I'd
expect the average American to say something like beTransient as an opposite
to bePersistent. Not a big deal, just an observation.
And please, don't take any of this as bitching, I'm not, you're one of my
favorite programmers. Much of my current style comes from things I've
learned reading Seaside and Magritte sources.
More information about the Seaside