[Seaside] Possible bug with <ul> generation?

Michel Bany michel.bany at gmail.com
Tue Feb 6 16:12:46 UTC 2007

On 06 Feb 2007, at 16:13 , Rick Flower wrote:

> I ran across this last night when perusing the generated code in my  
> test-web-app I've been working on (debugging firefox css issues I  
> had).. I have a block of code that populates an unordered list (for  
> the Canvas API).. The unordered list will contain the contents of a  
> shopping cart.  In this case if that cart is empty, I should  
> effectively get (in my opinion) an empty list.. However, what I got  
> was a single "</ul>" and nothing more.. I did not get the opening  
> html tag (e.g. <ul>).. I'm guessing that the generation of that may  
> be tied to the generation of a <li> item perhaps.. I've not  
> bothered looking at the code yet.. In this case I fixed my problem  
> and first check to see if my list is empty or not -- if it is then  
> I skip that entire unordered list generation block thereby getting  
> around the problem.
> Anyway, this is by no means an issue for me and perhaps that's the  
> way this is supposed to work, but I thought I'd see if anyone  
> thought it might be a bug or not..
> If you need some sample code, I could probably modify one of the  
> standard Seaside tests pretty easily..

Yes, please supply some sample code that produces the symptom.
I tried it hard here and could not come up with a case.

> P.S. I'm using Seaside 2.6b1.129.0 (1/19/2007) if that helps..
> _______________________________________________
> Seaside mailing list
> Seaside at lists.squeakfoundation.org
> http://lists.squeakfoundation.org/cgi-bin/mailman/listinfo/seaside

More information about the Seaside mailing list