[Seaside] Better selectors for jQuery script builders
johan at inceptive.be
Mon Sep 11 19:01:59 UTC 2017
> On 11 Sep 2017, at 19:14, Esteban A. Maringolo <emaringolo at gmail.com> wrote:
> OTOH I'd prefer it to be a verb (like "render") and that's why I'm
> moving away from the "script" prefix which I used until not so long
I would say it depends a bit more on your own coding convention.
We use the scriptXXX:on: naming convention.
I never thought of it this way, but I prefer keeping that convention instead of moving to a verb, as you decided to do.
My reasoning: our script methods always return a script and do not write on the canvas, like the render methods. The canvas is passed because you need it to generate JSObject and friends, but we settled on the convention that script methods return the script the produce, and it’s only written to the canvas in a render method.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the seaside