headless VM questions

Ian Piumarta piumarta at prof.inria.fr
Thu Jun 25 16:34:45 UTC 1998

> I've been running a Swiki on a Linux box at work.
> I recompiled the VM with -DHEADLESS, but when I start it up I still get a GUI.

I just tried this, and it appeared to work fine.  A transcript of the build
is appended.  I've placed a copy of the resulting executable in


on alix.inria.fr (sorry about the stale version of Linux -- my portable is
not switched on at present, and the Linux boxes at work are still in the
dark ages ;^).


---- begin transcript ----

bernin$ make mkdir
*** creating i586-linux-2.0.29...
bernin$ make CCFLAGS+=-DHEADLESS
make -C i586-linux-2.0.29
.../util/sqcat ../interp.c > interp.c
awk -f ../src/gnuify.trad < interp.c > gnu-interp.c
copying first section of file
interpret: adding static register assignments
interpret: adding bytecode dispatch table
interpret: rewriting case labels and outer breaks
primitiveResponse: adding primitive dispatch table
primitiveResponse: rewriting case labels
copying last section of file
gcc -DHEADLESS  -I../src/ -c gnu-interp.c
gcc -DHEADLESS  -I../src/ -c ../src/sqFilePrims.c
gcc -DHEADLESS  -I../src/ -c ../src/sqMiscPrims.c
gcc -DHEADLESS  -I../src/ -c ../src/sqOldSoundPrims.c
gcc -DHEADLESS  -I../src/ -c ../src/sqSoundPrims.c
gcc -DHEADLESS  -I../src/ -c ../src/sqUnixDirectory.c
gcc -DHEADLESS  -I../src/ -c ../src/sqUnixJoystick.c
gcc -DHEADLESS  -I../src/ -c ../src/sqUnixNetwork.c
gcc -DHEADLESS  -I../src/ -c ../src/sqUnixSerialAndMIDIPort.c
gcc -DHEADLESS  -I../src/ -c ../src/sqUnixSound.c
gcc -DHEADLESS  -I../src/ -c ../src/sqXWindow.c
.../util/verstamp sqUnixVersion.c 2.0h gcc
make sqUnixVersion.o
gcc -DHEADLESS  -I../src/ -c sqUnixVersion.c
ld -r  -o SqueakVM-2.0h-i586-linux-2.0.29.o gnu-interp.o sqFilePrims.o sqMiscPrims.o sqOldSoundPrims.o sqSoundPrims.o sqUnixDirectory.o sqUnixJoystick.o sqUnixNetwork.o sqUnixSerialAndMIDIPort.o sqUnixSound.o sqXWindow.o sqUnixVersion.o
gcc -DHEADLESS  -I../src/ -c ../src/sqUserPrims.c
gcc  -o SqueakVM-2.0h-i586-linux-2.0.29 SqueakVM-2.0h-i586-linux-2.0.29.o sqUserPrims.o -L/usr/X11R6/lib -lX11 -lXext -lm
bernin$ make CCFLAGS+=-DHEADLESS bin
make -C i586-linux-2.0.29 bin
[ -d ../bin ] || mkdir ../bin
cp SqueakVM-2.0h-i586-linux-2.0.29 ../bin
strip ../bin/SqueakVM-2.0h-i586-linux-2.0.29
.../bin/SqueakVM-2.0h-i586-linux-2.0.29 -version
2.0h/6502 #1 XShm Thu Jun 25 18:27:23 MEST 1998 gcc
Linux bernin 2.0.29 #3 Sat May 31 13:35:27 EST 1997 i586 unknown
No user-defined primitives installed
bernin$ ls -ltr bin
total 1152
-rwxr-xr-x   1 piumarta sor        294912 May 25 16:36 SqueakVM-2.0-alpha-osf1-v4.0*
-rwxr-xr-x   1 piumarta sor        214852 May 25 18:17 SqueakVM-2.0-sparc-solaris-2.5.1*
-rwxr-xr-x   1 piumarta sor        245760 May 25 18:20 SqueakVM-2.0-sparc-sunos-4.1.4*
-rwxr-xr-x   1 piumarta sor        143376 May 25 18:24 SqueakVM-2.0-i586-linux-2.1.24*
-rwxr-xr-x   1 piumarta sor        223964 Jun 25 18:28 SqueakVM-2.0h-i586-linux-2.0.29*
bernin$ ./i586-linux-2.0.29/SqueakVM-2.0h-i586-linux-2.0.29 Squeak2.0.image 

[at which point Squeak is running, with no GUI]

More information about the Squeak-dev mailing list