Magma isn't working.

tblanchard at tblanchard at
Fri Apr 25 23:52:41 UTC 2003

I ran into this as well - but I think it was because the parent 
directory didn't exist.
Once I created the parent directory it created the file.
I then launched the server and saved the image.
After relaunching the image (this time from the command line so I could 
get multiple executables going), the image's UI was frozen.  This was 
two weeks ago - I haven't tried since.

On Friday, April 25, 2003, at 02:50  PM, Raymond wrote:

> Le Vendredi, 25 avri 2003, à 05:57 America/Montreal, 
> goran.hultgren at a écrit :
>> Michael van der Gulik <mikevdg at> wrote:
>>> Ahh.. Magma isn't doing it for me. The first step fails:
>>>   MagmaRepositoryController
>>>     create: '/home/mikevdg/sq/myRepository.magma'
>>>     root: Dictionary new.
>>> I don't know how to cut&paste a stack dump, but it fails first with 
>>> an
>>> error:
>>> "MessageNotUnderstood: binary", and the offending message send seems 
>>> to
>>> be in "MaLargeCollectionOfIntegers>>create:" which looks like this:
>>> create: fileNameString
>>>     file _
>>>         (FileStream concreteStream new
>>>             open: fileNameString
>>>             forWrite: true) binary.
>>>     self writeHeader
>>> (FileStream concreteStream new) is a StandardFileStream, and the
>>> "binary" method seems to exist in that class.
>> snip-------
>> I haven't tested Magma under Linux myself (but I think Chris has) but
>> the error above has most surely nothing to do with Magma.
>> regards, Göran
> Hi Göran,  I don't know what system Michael van der Gulik use but I'm 
> using MasOs X and I got exactly the same error than Michael.
> Raymond

More information about the Squeak-dev mailing list