Ben Schroeder bschroeder at procro.com
Thu Jun 24 14:22:43 UTC 2004

On 6/24/04 8:53 AM, "Diego Tiscornia" <diegobt at hotmail.com> wrote:

> Hi ben, sorry I didn't answer before.
> Yes, you are right about the typo :/ thx
> Yes I think you got the FFi part working (for odbc, if you get that error)
> When you I got ODBCError, I debugged it and found out that the
> ODBCConnection object hadn't got an open connection, which meant it
> couldn't establish one, as my connection string was ok, (dsn, usr, pwd)
>   it turned out the problem was with iodbc and/or odbc.ini. What does
> the debugger tell you?
> By the way, I couldn't get the iodbc that shipped with mi mac to work,
> so I got bored and installed unixodbc from the fink distro, made that
> work and everything worked fine.
> hope this helps!

Hi Diego,

Thanks for your reply.  If I remember correctly, I did have something
similar to what you say: the driver had allocated handles correctly but
couldn't run SQLConnect.  The connection string seemed to be correct.

I tried creating the connection using a plain C program, and it failed there
too.  The nearest I could tell, the FreeTDS library was having trouble
dynamically loading the iodbc libraries that it needed.

Following a tip on another mailing list, I tried using the FreeTDS library
as the ODBC library directly, rather than going through iodbc, as its
interface is the same for at least many things.  (That is to say, I made the
symlink to the FreeTDS library file instead of to the iodbc one.)

This worked fine!  (... at least for the few things I've tried.)

I don't think I need a driver manager right now, but if I do, I may try
unixodbc - thanks for the tip.

I hope this helps anyone else trying to get this kind of thing working.

Thanks again for your installation notes and help!

Ben Schroeder

More information about the Squeak-dev mailing list