[SM][BUG] Error: can't find EOCD position

David T. Lewis lewis at mail.msen.com
Sun Oct 8 15:52:58 UTC 2006

On Sun, Oct 08, 2006 at 05:40:27PM +0200, karl wrote:
> David T. Lewis skrev:
> >A couple of my SqueakMap entries (maybe more, I have not checked them all)
> >have decided to stop working. I got the AioPlugin entry working again by
> >re-saving the entry, but XDisplayControlPlugin is screwed up and I can't
> >seem to convince it to start working again.
> >
> >What the user sees from a SqueakMap Package Loader is a debugger with
> >the rather unhelpful "Error: can't find EOCD position" message.
> >
> ><rant>
> >How many other SqueakMap entries are messed up and the authors don't
> >even know it? And what is a person supposed to  think when they see this?
> >It makes people think that AioPlugin and XDisplayControlPlugin are broken,
> >unmaintained, and unavailable, none of which is true.
> ></rant>
> >
> I have found that there is a bug in HttpSocket.
> Try the attached method which is a older version of the method that fails.
> I get things to work on windows with it. It also fixes an issue when 
> trying to
> access www.linuxfr.org from Scamper. I have not read trough the method
> to see what have changed that cause the bug.
> Karl

Thanks Karl,

I tried the patch you sent, but this seems to be a different problem.
I think SqueakMap keeps some sort of validity checks on the file links
and/or its internal caches, which apparently get screwed up at random
times for no apparent reason. Oh, and I was wrong, I did not get the
AioPlugin entry working, it's just broken differently now. I probably
should not have tried to "fix" it.


More information about the Squeak-dev mailing list