Debugging a headless image

Klaus D. Witzel klaus.witzel at
Thu Nov 8 14:42:07 UTC 2007

On Thu, 08 Nov 2007 15:28:43 +0100, Giovanni Corriga wrote:

> Il giorno gio, 08/11/2007 alle 15.25 +0100, Norbert Hartl ha scritto:
>> On Thu, 2007-11-08 at 15:16 +0100, Giovanni Corriga wrote:
>> > Hi all,
>> >
>> > I have a Pier image that I'd like to run on my server. It
>> > works fine if I start it in a VNC session, but if I run it with the
>> > -headless option I can't connect to it. Do you have any hints on the
>> > possible cause or on how to debug it?
>> >
>> Are you using the RemoteFramebuffer as VNC connection or do you use
>> a native one. With -headless you have to use the RemoteFramebuffer
>> from inside squeak because there is no other framebuffer to copy
>> from.
> No, I used the vncviewer that comes with Debian Sarge. But the problem
> isn't related to RFB/VNC, since when I run the image headless I can't
> even telnet the WAKom instance that is running.

After transfering a pier/seaside .image to my debian server, I invoke it  

... -memory 20m -vm-display-null name.of.image

Perhaps this helps.


> 	Giovanni

More information about the Squeak-dev mailing list