Debugging a headless image

Sebastian Sastre ssastre at
Thu Nov 8 15:53:36 UTC 2007

Hi Giovanni,

	I run several images with -headless without that problem. If you
want to perform internal diagnostic I think you can use:

	1. rST open in some port and connect from another headfull image
	2. do the same but with RemoteObjects
	3. Use the REPLServer from squeak map to telnet to the headless

Possible causes I don't know but I think I would make sure to try reloading
all (and not loading what is not needed) in a fresh image to guarantee the
"house is clean".



> -----Mensaje original-----
> De: squeak-dev-bounces at 
> [mailto:squeak-dev-bounces at] En 
> nombre de Giovanni Corriga
> Enviado el: Jueves, 08 de Noviembre de 2007 12:17
> Para: squeak-dev at
> Asunto: Debugging a headless image
> Hi all,
> I have a Pier image that I'd like to run on my 
> server. It works fine if I start it in a VNC session, but if 
> I run it with the -headless option I can't connect to it. Do 
> you have any hints on the possible cause or on how to debug it?
> 	Thanks,
> 		Giovanni

More information about the Squeak-dev mailing list