[squeak-dev] Metacello bootstrap fails due to download timeouts

Beckmann, Tom Tom.Beckmann at student.hpi.uni-potsdam.de
Tue Jul 14 06:28:27 UTC 2020

Ah sorry, I got confused with the various 32- vs 64-bit mentions.
Also, the SqueakSSL issue turned out to be just me forgetting that I did not have a well-configured 32bit environment.

I just tried running the Squot tests locally with squeak32-trunk on smalltalkCI, which turned out all green. For a couple hours now, smalltalkHub is also online again, so maybe the issues you were observing were all related to this part of the infrastructure failing and errors bubbling up to unexpected places? Or are the builds still failing on Travis?
From: Jakob Reschke <forums.jakob at resfarm.de>
Sent: Monday, July 13, 2020 11:37:51 PM
To: Beckmann, Tom
Cc: Tobias Pape; The general-purpose Squeak developers list; Henrichs, Dale (Gemtalksystems); Niephaus, Fabio
Subject: Re: Metacello bootstrap fails due to download timeouts

Beckmann, Tom <Tom.Beckmann at student.hpi.uni-potsdam.de<mailto:Tom.Beckmann at student.hpi.uni-potsdam.de>> schrieb am Mo., 13. Juli 2020, 19:47:

Concerning Squeak-trunk 32bit builds, I just tried to run one locally headful, and a failure occurs in primitiveSSLCreate, leading to a notification about ensuring to have internet and then a quiet image (see Installer>>ensureRecentMetacello, `self inform: ...`). I suppose we could consider changing this to an error instead, such that the CI build would fail rather than happily wait for ever after for you to click on the Okay button of the info window. Or, even better, create an Exception subclass for it that smalltalkCI can catch and handle appropriately, while by default the user sees the same info window.

Since that is not what I observed, we seem to have multiple such points of non-failures...

More information about the Squeak-dev mailing list