memory and VM issues (interp.c part 1 of 2 attached)

David T. Lewis lewis at
Mon Aug 1 10:54:23 UTC 2005

I tried ./dist3 image (i.e. VMM at whatever level it was at that
point), added GCImprovements-ar.cs, and built a VM that works fine.

I also tried loading GCImprovements-ar.cs after VMMaker-tpr.21.mcz,
but there are apparently a few other things to fix up in this
combination to produce a VM, so I can't really draw any conclusions
from this. But at this point the changes in GCImprovements-ar.cs
do not appear to be the source of the problem.


On Sun, Jul 31, 2005 at 11:48:30PM -0700, John M McIntosh wrote:
> Ok, well my code and  Andreas' code were at one point separate.
> I've attached Andreas' original changeset that dates from january and  
> you should be
> able to apply to a SVN 1100 pre 64 bit vmmaker setup. That should  
> tell us if the
> problem exists with his code.
> Don't apply my GCInstrumentJMMImprovementsAR.1.cs.
> On 31-Jul-05, at 7:43 PM, David T. Lewis wrote:
> > On Fri, Jul 29, 2005 at 01:03:31PM -0700, Tim Rowledge wrote:
> >
> >> Could you try a 3.8-6665 image, SVN revision 1100, VMMaker38b4 combo?
> >> That is the last pre-64bit-fiddling build and should work ok. One  
> >> thing
> >> we're a bit concerned with is the changes to GC/weak objects that got
> >> put in later.
> >>
> >

More information about the Vm-dev mailing list