[Vm-dev] bug leaving Scratch presentation mode with squeak-vm 4.10.2-2614

Matthew Miller mattdm at mattdm.org
Tue Jan 22 20:41:59 UTC 2013

Hi! I'm _finally_ getting all the parts in place for Scratch on Fedora
Linux. It's all working well, but there's one bug I've noticed: when I exit
full-screen presentation mode, I get a blank white window which doesn't
respond to anything. I'm launching Scratch like this:

  squeak -encoding UTF-8 -vm-sound-pulse /usr/share/scratch/Scratch.image

with no -xshm or anything else. This uses the scratch plugin from squeak
itself, but I'm getting the same behavior when I build the one in the
scratch source too.

I tried the shift-r trick and turned full screen off; when I return from
presentation mode, I still get the unresponsive screen (I thought maybe I
could get a squeak menu in that case, but no luck).

I asked on the Scratch list, and it was suggested that this was probably a
VM problem and that this would be the best place to ask. Anyone have any
insight or ideas on how to proceed to debug this?

Matthew Miller           mattdm at mattdm.org          <http://mattdm.org/>

More information about the Vm-dev mailing list