[Vm-dev] a question about building ARM support code in processors

Tim Olson tim.olson.mail at gmail.com
Sun Oct 18 13:04:04 UTC 2015

On Oct 18, 2015, at 5:26 AM, Robert Withers <robert.w.withers at gmail.com> wrote:

> I found some support code for the ARM plugin, in the processors directory. Following the instructions, I noticed there was no step to run make in the sim/common directory, though it has a Makefile and contains .c files.
> I carried on and when running make in sim/arm I received these errors multiple times:
> ../../include/libiberty.h:92:22: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘PARAMS’
> wrapper.c:135:20: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘VPARAMS’
> Any help resolving this is received with gratitude.

I ran into this problem when getting this to build on my 64-bit Ubuntu system.  The problem is that the system’s ansidecl.h is incompatible with the one that should be used (in include/ansidecl.h in the ARM gdb directory).  I fixed it by moving the include of ansidecl.h first before any other includes in the sim/arm/wrapper.c file:

/* TAO -- include local version of ansidecl.h first to ensure it is used instead of the system's version */
#include "ansidecl.h"
#include "config.h"
#include <stdio.h>
#include <stdarg.h>
#include <string.h>

	— tim

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.squeakfoundation.org/pipermail/vm-dev/attachments/20151018/61fcbe64/attachment-0001.htm

More information about the Vm-dev mailing list