2.3 for Unix

Douglas Brebner douglas+list at fang.demon.co.uk
Sat Feb 6 01:26:04 UTC 1999

On 05-Feb-99, Juan Cires Martinez wrote:
>  > >   I defined DEBUG, tried again and no messages were produced on stderr.
>  > >   Do any of you have any idea where should I be looking?
>  >
>  >  Silly question, but did you change the #undef DEBUG in
>  >  sqUnixExternalPrimitived.c ? (I should have mentioned that before :( )
>   I also thought something like this was wrong and opted to remove that
>   line, issue a
>    #define DEBUG
>   and to hardcode the #define dprintf.  Still no new messages.  By the
>   way, I open a flash file that I have on disk.

Just changing the #undef DEBUG to #define DEBUG should have worked.

Try replacing the dprintf's with fprintf to force output or sending it
to stdout or a file.

With DEBUG defined I got the following *while* loading a flash file:

loading: <intrinsics>
handle:  0x1                             <- found module
resolve: `primitiveFloatArrayAtPut'      <- Name should match nm output
address: 0x0                             <- failed to find symbol
No such file or directory                <- awful error msg :(
handle:  0x1
resolve: `primitiveFloatArrayAtPut'
address: 0x0
No such file or directory

and so on. Similar for Play With Me 3.

It's possible all your pluggable prims fail but most have Smalltalk
code which replace the primitive thus hiding the error.
gePrimitiveInitializeBuffer and friends don't. They just fail.


E-Mail:  douglas+mail at fang.demon.co.uk

Content-Type: text/plain; name="squeak.log"
Content-Disposition: attachment; filename="squeak.log"
Content-Description: Log of successful Flash file open

Attachment converted: Anon:squeak.log (TEXT/MSIE) (000068F8)

More information about the Squeak-dev mailing list