[BUG] 2.3 VMs hang on 68K

O'NEEL Bruce beoneel at mindspring.com
Tue Feb 23 09:12:34 UTC 1999

  The 2.3 68k VMs won't run on PPC macs anymore.  They are cfm68k apps 
and those aren't emulated.  Yes, Apple really should have come up with 
a better error message then Illegal instruction :-)

  What version of MacOS does your 190 use?  My 520 with an LC040 runs
the 68k VM just fine with MacOS 8.1.  According to the readmeFile in


1. You now need to use the CFM versions of the library files. The 68K
project file has been updated accordingly.

2. You cannot run the 68K VM under the emulator on the PowerPC (Apple
doesn''t support CFM apps under the 68K emulator).

3. You need to be sure that version 4.0 or later of "CFM-68K Runtime
Enabler" is in the Extensions folder of the system folder on your 68K
Mac. *** Warning: Older versions of "CFM-68K Runtime Enabler" had bugs
that will probably prevent Squeak from even starting! ***.

4. You will need to figure out how to make a CFM68K shared library
project if you wish to build dynamic primitives that can be run on the
68K. Ideally, one would create a "fat" library containing both 68K and
PPC versions of the dynamically loadable primitives. So far, I have
not tried doing that.


My guess is that #3 is killing you.  If you have MacOS 7.x then you
need to get the CFM68k extension to get the VM to run.  If you
don't have it you should get a nice error message, but, you could also 
get a crash.  As of MacOS 8 the CFM68k extension is included in the
System file so you don't need it any more.  If you can't find CFM68k
4.0 on Apple's site I'm happy to dig it up for you.

good luck!




Mark Guzdial writes:
 > I can't get either 2.3 or 2.3b 68K VMs to run on my Powerbook 190cs (68040
 > based), even with no extensions on.  I was having problems running the 68K
 > VMs on my G3 -- I thought that they should (via the 68K emulator), but I
 > chalked it up to non-backwards-compatibility. But now that I've tried on an
 > actual 68K box, I'm quite sure that it's the VMs.
 > Sometimes, I get an illegal instruction error in Macsbug, error 10 with no
 > extensions on.  Most often, though, the mouse cursor freezes and
 > everything's dead.
 > Mark

More information about the Squeak-dev mailing list