Local SqueakSource Server

Adrian Lienhard adi at netstyle.ch
Fri Jun 1 07:37:14 UTC 2007

It's a pitty that installing something like SqueakSource is so  
One of the problems seems to be that SqueakMap does not work in your  
3.7 image (there have been various issues with SqueakMap IIRC).  
Anyway, if you follow the description on the Wiki page http:// 
source.squeakfoundation.org/ss.html I think you get around SqueakMap  
since all packages are in the repository of SqueakSource-SqF itself.


On May 31, 2007, at 21:13 , Matthew Fulmer wrote:

> I am trying to install a SqueakSource Server on my home machine
> in order to try creating an email-based commit notifier. I have
> tried several combinations of 3.7 image, 3.8 image, and 3.9
> images
> Things I have tried:
> - Loading http://www.squeaksource.com/ss/SqueakSource-dt.1020.mcz
>   into a full 3.7 or 3.8 image. This Installs fine, but does not
>   run because DynamicBindings is missing.
>   - After installing DynamicBindings from SqueakMap onto a 3.8
>     image, the server fails when a page is loaded with:
>     MessageNotUnderstood: UndefinedObject>>title. I am not sure how
>     to get a traceback.
>   - I could not test on a 3.7 image, because I cannot load
>     SqueakMap; It tries to update to 2.2, and fails.
> - Following the instructions on the wiki page for
>   http://source.squeakfoundation.org/ss/ fails because I cannot use
>   SqueakMap; same problem as above
> - Following the instructions at
>   http://osdir.com/ml/lang.smalltalk.squeak.beginners/2006-12/ 
> msg00098.html
>   on a squeak-dev-118 image works until I load the package
>   http://www.squeaksource.com/ss/GraphViz-pmm.43.mcz , which fails
>   with a syntax error on
>   MacOSGraphVizGenerator>>runWithSystemFramework:
>   - Trying on the recommended squeak-dev-62 image, Monticello fails
>     with an error when reading the KomServices package:
>     MessageNotUnderstood: UndefinedObject>>readStream.
>   - I try downloading the packages manually, and the web server
>     says that http://www.squeaksource.com/ss/XML-Parser-mir.3.mcz
>     cannot be found.
> So, I tried four methods of installing SqueakSource, and ran into 5
> show-stoppers. How can one install SqueakSource?
> -- 
> Matthew Fulmer -- http://mtfulmer.wordpress.com/
> Help improve Squeak Documentation: http://wiki.squeak.org/squeak/808

More information about the Squeak-dev mailing list