[squeak-dev] Re: running headless

Klaus D. Witzel klaus.witzel at cobss.com
Sat Oct 25 13:26:50 UTC 2008

On Sat, 25 Oct 2008 15:00:04 +0200, Damien Pollet wrote:

> On Thu, Oct 23, 2008 at 5:47 AM, David T. Lewis <lewis at mail.msen.com>  
> wrote:
>> The "-headless" option definitely works for the unix VM. I don't know
>> about OS X or Windows.
> There is also -nodisplay. From what I understand, -headless just
> prevents the VM from opening its window (so you still need to run a
> graphics server), and -nodisplay loads a dummy display plugin, so in
> theory you don't even need the X11 libraries on the machine.
> Now I'm also trying to run a headless image on linux, but nothing
> happens.

I run the Squeak VM with -memory 20m -vm-display-null under Linux (debian)  
as a daemon and for being able to listen it needs to be empowered (which  
is often forgotten).

If you're logged on as root, does it do what you want when started from  
command line?

> There is a WAKom + Seaside running in the image but it
> doesn't listen. Since squeak doesn't give any hint of whichever state
> it's in…
> Only problem I see is that some plugins require X11 even though I ran
> configure with --without-x, so at least there is a bug in the autoconf
> scripts.
> NB. The exact same image runs perfectly fine on Mac (headless or not).

“If at first, the idea is not absurd, then there is no hope for it”.  
Albert Einstein

More information about the Squeak-dev mailing list