[squeak-dev] Sound mixing makes nasty noises

Herbert König herbertkoenig at gmx.net
Thu Dec 24 21:05:41 UTC 2020

Am 24.12.2020 um 21:36 schrieb tim Rowledge:
>> On 2020-12-24, at 12:18 PM, Herbert König <herbertkoenig at gmx.net> wrote:
>> Hi Tim,
>> ATM I get no sound from Squeak or Scratch on my Raspi3. I updated the OS
>> but it still doesn't say "Raspberry Pi OS"
> Hmm, updating a Pi can be confusing at times.
> If you do
> `uname -a` in a terminal, what do you see?
> On my still-alsa machine I get
> Linux Goldskin 5.4.51-v7l+ #1333 SMP Mon Aug 10 16:51:40 BST 2020 armv7l GNU/Linux
Linux herpi2 5.4.79-V7+ .. Rest same as yours above.
> On my test-pulse I get
> Linux Pi-4-1-pulse 5.4.79-v7l+ #1373 SMP Mon Nov 23 13:27:40 GMT 2020 armv7l GNU/Linux
> Remember that you need to include the vm sound flag when you start up squeak! I keep forgetting that. Though.. if you're start scratch with the standard menu entry, that should do it. Let's see - there is also the possibility you are not directing sound to the right output. The Pi sound-volume control widget on the menubar can set where the sound goes - right-click on it and you should see a menu with at least
>    Analogue
>    HDMI
> entries. I use the analogue and headphones since none of my Pi have a direct HDMI display attached but go via VNC. If you have an HDMI monitor attached it may not have speakers or you might not have them turned on! DAMHIKT.
I use the 3.5mm headphone output and verified that via Audacity and VLC.
I have a cheap active speaker connected. Just checked: Scratch 2 plays
sound Scratch1 started via the menu doesn't. Now downloading a fresh Squeak.

I tried the -vmsound alsa and pulse but I'm not sure If I used the right
place in the script. I tried editing the last line to:
exec "${VM}" "-vm-sound-alsa" "${IMAGE}"  (and pulse and w/o the "" but
my Linux fu is not enough to know if that's ok.



>> With some googling I got Audio working from Audacity (simple Audio
>> Editor I use on Raspi, Linux and Windows). I use Squeak5.3-19439.
>> Recording with a phone will show some glitches but the bandwidth of
>> phone (and monitor speakers) mellows down (err filters) the waveform.
>> Surely only second choice.
>> I would not mind downloading and using the proper Squeak to get sound going.
> The 5.3 armlinux package from squeak.org ought to do ok for this. Remembering of course to include that '-vm-sound-alsa' (or pulse) in your commandline
> tim
> --
> tim Rowledge; tim at rowledge.org; http://www.rowledge.org/tim
> Strange OpCodes: PRM: PRint Money

More information about the Squeak-dev mailing list